Главная » ЭКСП » error occurred when installing package pycharm – как исправить

error occurred when installing package pycharm – как исправить

Solution 1: Reconfiguring the dpkg Package

One of the triggers of this error is a corrupted dpkg database. This can be caused by the sudden interruption of the installation of a software package. Reconfiguring the database is one way to resolve this issue.

To do this, simply execute the command:

$ sudo dpkg –configure -a

This reconfigures the unpacked packages that were not installed during the installation process.

Solution 2: Force Install the Troublesome Package

Sometimes, errors can occur during the installation of software packages. When such happens, you can force install the package using the -f option as shown.

$ sudo apt install -f
OR
$ sudo apt install –fix-broken

The -f option & –fix-broken can be interchangeably used to fix broken dependencies resulting from an interrupted package or cached package download.

Solution 3: Purge the Bad or Corrupted Software Package

If the first two solutions did not fix the problem, you can remove or purge the problematic software package as shown.

$ sudo apt remove –purge package_name

For example, in my case, purging the Google chrome package fixed the issue.

$ sudo apt remove –purge google-chrome-stable

Then invoke the commands below to remove all the old, unused, and unnecessary packages which also frees up space on your hard drive.

$ sudo apt clean
$ sudo apt autoremove

Solution 4: Remove all the Files Associated with the Package

Lastly, you can manually remove all the associated with the troublesome package. First, you need to find these files which are located in the /var/lib/dpkg/info directory as shown.

$ sudo ls -l /var/lib/dpkg/info | grep -i package_name

After listing the files, you can move them to the /tmp directory as shown

$ sudo mv /var/lib/dpkg/info/package-name.* /tmp

Alternatively, you can use the rm command to manually remove the files.

$ sudo rm -r /var/lib/dpkg/info/package-name.*

Finally, update the package lists as shown:

$ sudo apt update

You can thereafter give it another shot in reinstalling the software package.

Конфликт зависимостей модулей Python

Иногда может существовать конфликт модулей Python, который и приводит к ошибке No module named.

Следующее сообщение явно указывает, что _numpy_compat.py в библиотеке scipy пытается импортировать модуль numpy.testing.nosetester.

Traceback (most recent call last):
File “C:demo-projectvenv
Libsite-packages
scipy_lib_numpy_compat.py”, line 10, in
from numpy.testing.nosetester import import_nose
ModuleNotFoundError: No module named ‘numpy.testing.nosetester’

Ошибка ModuleNotFoundError возникает из-за того, что модуль numpy.testing.nosetester удален из библиотеки в версии 1.18. Для решения этой проблемы нужно обновить numpy и scipy до последних версий.

pip install numpy –upgrade
pip install scipy –upgrade

Теперь выполните следующие действия

PyCharm > Настройки > Настройки проектa > Django

Убедитесь, что ваши Django Project root, settings.py и manage.py script четко определены в диалоговом окне.

Вы хорошо пойдете.
Надеюсь это поможет.

Ответ 3

Я сделал все вышеперечисленное из einnocent и myildirim, но все равно должен был сделать следующее:

закрыть pycharm и вручную удалить папку .idea, это удалит все, что pycharm знает о коде.

открыть pycharm, reimport проект

комбинация установки правильного корня источника, перезапуск python с invalide cache и удаление папки .idea/реимпорт проекта pycharm исправили его для меня.

Ответ 4

Я столкнулся с аналогичной проблемой с pyspark (искра 2.1) и luigi.

Сбой попытки:

  • Настройка переменной среды PYTHONPATH
  • Недействительный кеш и перезапуск pycharm
  • Отметьте каталог как Корень источника

Неразрешенная ссылка pyspark может быть исправлена ​​путем добавления каталога искрового питона в Content Root в проекте, но запуск проекта в качестве задачи luigi дал та же ошибка.

Успешные шаги

  • Создайте пустой __init__.py файл в проекте
  • Включите следующие строки кода вверху script


    import sys

    sys.path.append(“/path/to/spark/python”)

    sys.path.append(“/path/to/spark/python/lib”)


    // import pyspark files after above mentioned lines

и нерешенной проблемой ссылка ошибка была исправлена ​​как в PyCharm и задачи LuiGi.

Ответ 5

Другой причиной может быть проектный интерпретатор. Например, если вы используете Python3.x, но интерпретатор предназначен для Python2.x. Вы можете проверить здесь:

Файл | Настройки | Проект: ‘projectname’ | Переводчик проекта

Ответ 6

PyCharm – Alt-F (ile); Настройки; Структура проекта; нажмите + добавить корневой контент;
укажите свою папку, содержащую пакет, в конфликте:/home/joker/anaconda3/envs/conda_py27/lib/python2.7/site-packages.
Я дополнительно отмечен как ресурсы (не уверен, что это обязательно). Нажмите “ОК”, и произойдет переиндексация.
Эта решила проблему для меня в PyCharm Professional 2016.2.3

Установлена новая версия модуля, но программа видит старую версию

Я несколько раз сталкивался с подобными необъяснимыми ошибками.

Иногда помогает удаление модуля командой вида:

sudo pip2 uninstall модуль

Также попробуйте удалить его используя системный менеджер пакетов.

Если модуль вам нужен, попробуйте вновь установить его и проверьте, решило ли это проблему.

Если проблема не решена, то удалите все файлы модуля, обычно они расположены в папках вида:

  • /usr/lib/python2.7/site-packages/модуль
  • /usr/lib/python3.7/site-packages/модуль

Пакет Python установлен, но программа его не видит

Причина может быть в том, что вы установили модуль для другой версии. Например, программа написана на Python3, а вы установили модуль с этим же названием, но написанный на Python2. В этом случае он не будет существовать для программы. Поэтому нужно правильно указывать номер версии.

Команда pip также имеет свои две версии: pip2 и pip3. Если версия не указана, то это означает, что используется какая-то из двух указанных (2 или 3) версий, которая является основной в системе. Например, сейчас в Debian и производных по умолчанию основной версией Python является вторая. Поэтому в репозитории есть два пакета: python-pip (вторая версия) и python3-pip (третья).

В Arch Linux и производных по умолчанию основной версией является третья, поэтому в репозиториях присутствует пакет python-pip (третья версия) и python2-pip (вторая).

Это же самое относится к пакетам Python и самому Python: если версия не указана, значит имеется ввиду основная для вашего дистрибутива версия. По этой причине многие пакеты в репозитории присутствуют с двумя очень похожими названиями.

Конфликт имен библиотеки и модуля

Еще одна причина ошибки No module named — конфликт в названиях пакета и модуля. Предположим, есть следующая структура проекта Python:

demo-project
└───utils
__init__.py
string_utils.py
utils.py

Если использовать следующую инструкцию импорта файла utils.py, то Python вернет ошибку ModuleNotFoundError.

Use a different BrowserСкопированоКопировать
>>> import utils.string_utils
Traceback (most recent call last):
File “C:demo-projectutilsutils.py”, line 1, in
import utils.string_utils
ModuleNotFoundError: No module named ‘utils.string_utils’;
‘utils’ is not a package

В сообщении об ошибке сказано, что «utils is not a package». utils — это имя пакета, но это также и имя модуля. Это приводит к конфликту, когда имя модуля перекрывает имя пакета/библиотеки. Для его разрешения нужно переименовать файл utils.py.

Ошибки с фразой «AttributeError: ‘NoneType’ object has no attribute»

Ошибки, в которых присутствует слово AttributeError, NoneType, object has no attribute обычно вызваны не отсутствием модуля, а тем, что модуль не получил ожидаемого аргумента, либо получил неправильное число аргументов. Было бы правильнее сказать, что ошибка вызвана недостаточной проверкой данных и отсутствием перехвата исключений (то есть программа плохо написана).

В этих случаях обычно ничего не требуется дополнительно устанавливать. В моей практике частыми случаями таких ошибок является обращение программы к определённому сайту, но сайт может быть недоступен, либо API ключ больше недействителен, либо программа не получила ожидаемые данные по другим причинам. Также программа может обращаться к другой программе, но из-за ошибки в ней получит не тот результат, который ожидала, и уже это вызывает приведённые выше ошибки, которые мы видим.

Опять же, хорошо написанная программа в этом случае должна вернуть что-то вроде «информация не загружена», «работа программы N завершилась ошибкой» и так далее. Как правило, нужно разбираться с причиной самой первой проблемы или обращаться к разработчику.

Parse the results

Result

Action

The package cannot be installed because the Python version doesn’t satisfy the package requirement.

Try to create another Python interpreter that is based on the Python version that meets the requirement.

The package cannot be installed because you don’t have permissions to install it.

Try to install the package using super-user privileges, for example, sudo pip install

.

The package cannot be installed because the package is not available in the repository that is supported by the selected package manager. Example: you’re trying to install a package that is not available in the Conda package manager repositories.

Try to configure another type of Python interpreter for your project and install the package on it. See how to add and modify a Python interpreter in Configure a Python interpreter.

The package cannot be installed and it matches one of the typical package installation failure cases.

Check the cases and apply related workarounds.

The package is successfully installed.

File an issue in the PyCharm issue tracker and provide explicit details about the case including all console output, error messages, and screenshots indicating that you tried to install the package on the same interpreter in the terminal and in the project settings or in the Python Packages tool window.

Источники

  • https://www.tecmint.com/sub-process-usr-bin-dpkg-returned-an-error-in-ubuntu/
  • https://PythonRu.com/baza-znanij/no-module-named
  • https://utyatnishna.ru/info/34543/pycharm-unresolved-reference-error-on-the-ide-when-opening-a-working-project
  • https://ZaLinux.ru/?p=1960
  • https://www.jetbrains.com/help/pycharm/package-installation-issues.html
[свернуть]
Решите Вашу проблему!


×
Adblock
detector